using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/)(?!.*changelogs)(?:\/[^\/]+)*\/(\d+)\/{0,1}";
string input = @"http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/docs/changelogs/anythingelse/anything/1215/
http://www.opera.com/security/advisory/1047
http://www.opera.com/security/advisory/1048/
http://www.opera.com/doesnt/matter/could/be/anything/1049/
http://www.opera.com/docs/changelogs/unified/1288/
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}