const regex = /(?:\/)(?!.*changelogs)(?:\/[^\/]+)*\/(\d+)\/{0,1}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/)(?!.*changelogs)(?:\\\/[^\\\/]+)*\\\/(\\d+)\\\/{0,1}', 'gmi')
const str = `http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/docs/changelogs/anythingelse/anything/1215/
http://www.opera.com/security/advisory/1047
http://www.opera.com/security/advisory/1048/
http://www.opera.com/doesnt/matter/could/be/anything/1049/
http://www.opera.com/docs/changelogs/unified/1288/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}