import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/)(?!.*changelogs)(?:\\/[^\\/]+)*\\/(\\d+)\\/{0,1}";
final String string = "http://www.opera.com/docs/changelogs/unified/1215/\n"
+ "http://www.opera.com/docs/changelogs/anythingelse/anything/1215/\n"
+ "http://www.opera.com/security/advisory/1047\n"
+ "http://www.opera.com/security/advisory/1048/\n"
+ "http://www.opera.com/doesnt/matter/could/be/anything/1049/\n"
+ "http://www.opera.com/docs/changelogs/unified/1288/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}