import Foundation
let pattern = #"(?:\/)(?!.*changelogs)(?:\/[^\/]+)*\/(\d+)\/{0,1}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/docs/changelogs/anythingelse/anything/1215/
http://www.opera.com/security/advisory/1047
http://www.opera.com/security/advisory/1048/
http://www.opera.com/doesnt/matter/could/be/anything/1049/
http://www.opera.com/docs/changelogs/unified/1288/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)