#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SELECT \* FROM (`)?\w+\1 WHERE .*"
Local $sString = "SELECT * FROM `commands` WHERE `UID` LIKE '70f8b955-fe64-4efe-8976-737c77c12c4b' AND `InsertTime` > '1464091507' OR `UID` LIKE "" AND `InsertTime` > '1464091507'$checkin:5000;#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")