import Foundation
let pattern = #"SELECT \* FROM (`)?\w+\1 WHERE .*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"SELECT * FROM `commands` WHERE `UID` LIKE '70f8b955-fe64-4efe-8976-737c77c12c4b' AND `InsertTime` > '1464091507' OR `UID` LIKE "" AND `InsertTime` > '1464091507'$checkin:5000;#"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)