#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w]+(?=,))?(?:.*\b(\w+).+\b\w+)?"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"I'll say!" & @CRLF & _
"moroz i solnce, den' chydesnyj!" & @CRLF & _
"Eche ti drishesh, dryg prelestniy" & @CRLF & _
"Pora, krasavitca, privet`:" & @CRLF & _
"Otkroy somknyti negoy vzori"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")