import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w]+(?=,))?(?:.*\\b(\\w+).+\\b\\w+)?";
final String string = "\n\n"
+ "I'll say!\n"
+ "moroz i solnce, den' chydesnyj!\n"
+ "Eche ti drishesh, dryg prelestniy\n"
+ "Pora, krasavitca, privet`:\n"
+ "Otkroy somknyti negoy vzori";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}