$re = '~^([\w]+(?=,))?(?:.*\b(\w+).+\b\w+)?~m';
$str = '
I\'ll say!
moroz i solnce, den\' chydesnyj!
Eche ti drishesh, dryg prelestniy
Pora, krasavitca, privet`:
Otkroy somknyti negoy vzori';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);