re = /^([\w]+(?=,))?(?:.*\b(\w+).+\b\w+)?/m
str = '
I\'ll say!
moroz i solnce, den\' chydesnyj!
Eche ti drishesh, dryg prelestniy
Pora, krasavitca, privet`:
Otkroy somknyti negoy vzori'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end