using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;]*);([^;]*);([^;]*);$";
string substitution = @"$3;$1;$2;";
string input = @"#x93F;#x902;#x91C;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}