const regex = /^([^;]*);([^;]*);([^;]*);$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;]*);([^;]*);([^;]*);$', 'gm')
const str = `#x93F;#x902;#x91C;`;
const subst = `$3;$1;$2;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);