$re = '/^([^;]*);([^;]*);([^;]*);$/m';
$str = '#x93F;#x902;#x91C;';
$subst = "$3;$1;$2;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;