import Foundation
let pattern = #"^([^;]*);([^;]*);([^;]*);$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"#x93F;#x902;#x91C;"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3;$1;$2;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)