using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"192_168_\d{1,3}_\d{1,3}";
string input = @"hello82
8dffhjfhd
dfdfd6
192_168_2_8
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}