// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)192_168_\d{1,3}_\d{1,3}").unwrap();
let string = "hello82
8dffhjfhd
dfdfd6
192_168_2_8
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}