#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?= {0,4}[+-]?[1-9]\d*$)(?P<X>.{5})"
Local $sString = "12345" & @CRLF & _
"+2345678" & @CRLF & _
"-2345678" & @CRLF & _
" +2345678" & @CRLF & _
" +2-345678" & @CRLF & _
" 1" & @CRLF & _
"[2345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")