using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?= {0,4}[+-]?[1-9]\d*$)(?P<X>.{5})";
string input = @"12345
+2345678
-2345678
+2345678
+2-345678
1
[2345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}