import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?= {0,4}[+-]?[1-9]\\d*$)(?P<X>.{5})";
final String string = "12345\n"
+ "+2345678\n"
+ "-2345678\n"
+ " +2345678\n"
+ " +2-345678\n"
+ " 1\n"
+ "[2345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}