const regex = new RegExp('^(?= {0,4}[+-]?[1-9]\\d*$)(?P<X>.{5})', 'mg')
const str = `12345
+2345678
-2345678
+2345678
+2-345678
1
[2345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}