#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(StartMarker:[\s\S]*?)(?=(?:\r?\n)+StartMarker:|$)"
Local $sString = "StartMarker:" & @CRLF & _
"Line1" & @CRLF & _
"Line2" & @CRLF & _
"Line3" & @CRLF & _
"Line4" & @CRLF & _
"Line5" & @CRLF & _
"" & @CRLF & _
"StartMarker:" & @CRLF & _
"Line6" & @CRLF & _
"Line7" & @CRLF & _
"Line8" & @CRLF & _
"" & @CRLF & _
"StartMarker:" & @CRLF & _
"Line9" & @CRLF & _
"Line10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")