import Foundation
let pattern = #"(StartMarker:[\s\S]*?)(?=(?:\r?\n)+StartMarker:|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
StartMarker:
Line1
Line2
Line3
Line4
Line5
StartMarker:
Line6
Line7
Line8
StartMarker:
Line9
Line10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)