const regex = /(StartMarker:[\s\S]*?)(?=(?:\r?\n)+StartMarker:|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(StartMarker:[\\s\\S]*?)(?=(?:\\r?\\n)+StartMarker:|$)', 'g')
const str = `StartMarker:
Line1
Line2
Line3
Line4
Line5
StartMarker:
Line6
Line7
Line8
StartMarker:
Line9
Line10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}