$re = '/(StartMarker:[\s\S]*?)(?=(?:\r?\n)+StartMarker:|$)/';
$str = 'StartMarker:
Line1
Line2
Line3
Line4
Line5
StartMarker:
Line6
Line7
Line8
StartMarker:
Line9
Line10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);