import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[01]?\\d?\\d|2[0-4]\\d|25[0-5])\\.){3}(?:(?:[01]?\\d?\\d|2[0-4]\\d|25[0-5]))";
final String string = "256.\n"
+ "1.1.1.1\n"
+ "10.\n"
+ "100.100.100.100\n"
+ "255.\n"
+ "249.\n"
+ "0.0.0.0\n"
+ "300.\n"
+ "01.\n"
+ "022.\n"
+ "001.\n"
+ "0001.\n"
+ "192.168.1.1\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}