import re
regex = re.compile(r"^(?:(?:[01]?\d?\d|2[0-4]\d|25[0-5])\.){3}(?:(?:[01]?\d?\d|2[0-4]\d|25[0-5]))", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("256.\n"
"1.1.1.1\n"
"10.\n"
"100.100.100.100\n"
"255.\n"
"249.\n"
"0.0.0.0\n"
"300.\n"
"01.\n"
"022.\n"
"001.\n"
"0001.\n"
"192.168.1.1\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")