re = /^(?:(?:[01]?\d?\d|2[0-4]\d|25[0-5])\.){3}(?:(?:[01]?\d?\d|2[0-4]\d|25[0-5]))/im
str = '256.
1.1.1.1
10.
100.100.100.100
255.
249.
0.0.0.0
300.
01.
022.
001.
0001.
192.168.1.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end