const regex = /^(?:(?:[01]?\d?\d|2[0-4]\d|25[0-5])\.){3}(?:(?:[01]?\d?\d|2[0-4]\d|25[0-5]))/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[01]?\\d?\\d|2[0-4]\\d|25[0-5])\\.){3}(?:(?:[01]?\\d?\\d|2[0-4]\\d|25[0-5]))', 'img')
const str = `256.
1.1.1.1
10.
100.100.100.100
255.
249.
0.0.0.0
300.
01.
022.
001.
0001.
192.168.1.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}