#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!AN-)\b(?:(?!AN-\d+)[\w]+)\b"
Local $sString = "2 BILLING ID AN-19 RPS Ex : “00411850177 “" & @CRLF & _
"3" & @CRLF & _
"FILLER AN-11 RPS EX: “ “" & @CRLF & _
"4" & @CRLF & _
"FILLER AN-15 RPS EX: “ “" & @CRLF & _
"5" & @CRLF & _
"FILLER AN-30 RPS EX: “ “" & @CRLF & _
"6" & @CRLF & _
"FILLER AN-2 RPS EX: “ “" & @CRLF & _
"7" & @CRLF & _
"FILLER AN-1 RPS EX: “ “" & @CRLF & _
"8 BILLER CODE AN-4 RPS Ex : “1310”" & @CRLF & _
"1302 means PDAM Mitracom" & @CRLF & _
"9" & @CRLF & _
"FILLER AN-11 RPS EX: “ “" & @CRLF & _
"10 ADMIN FEE N-12 LPZ Ex : “000000075000”" & @CRLF & _
"11 FILLER AN-11 RPS EX: “ “" & @CRLF & _
"12 FILLER AN-12 RPS EX: “ “" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")