import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!AN-)\\b(?:(?!AN-\\d+)[\\w]+)\\b";
final String string = "2 BILLING ID AN-19 RPS Ex : “00411850177 “\n"
+ "3\n"
+ "FILLER AN-11 RPS EX: “ “\n"
+ "4\n"
+ "FILLER AN-15 RPS EX: “ “\n"
+ "5\n"
+ "FILLER AN-30 RPS EX: “ “\n"
+ "6\n"
+ "FILLER AN-2 RPS EX: “ “\n"
+ "7\n"
+ "FILLER AN-1 RPS EX: “ “\n"
+ "8 BILLER CODE AN-4 RPS Ex : “1310”\n"
+ "1302 means PDAM Mitracom\n"
+ "9\n"
+ "FILLER AN-11 RPS EX: “ “\n"
+ "10 ADMIN FEE N-12 LPZ Ex : “000000075000”\n"
+ "11 FILLER AN-11 RPS EX: “ “\n"
+ "12 FILLER AN-12 RPS EX: “ “\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}