# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!AN-)\b(?:(?!AN-\d+)[\w]+)\b"
test_str = ("2 BILLING ID AN-19 RPS Ex : “00411850177 “\n"
"3\n"
"FILLER AN-11 RPS EX: “ “\n"
"4\n"
"FILLER AN-15 RPS EX: “ “\n"
"5\n"
"FILLER AN-30 RPS EX: “ “\n"
"6\n"
"FILLER AN-2 RPS EX: “ “\n"
"7\n"
"FILLER AN-1 RPS EX: “ “\n"
"8 BILLER CODE AN-4 RPS Ex : “1310”\n"
"1302 means PDAM Mitracom\n"
"9\n"
"FILLER AN-11 RPS EX: “ “\n"
"10 ADMIN FEE N-12 LPZ Ex : “000000075000”\n"
"11 FILLER AN-11 RPS EX: “ “\n"
"12 FILLER AN-12 RPS EX: “ “\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.