import Foundation
let pattern = #"(?<!AN-)\b(?:(?!AN-\d+)[\w]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2 BILLING ID AN-19 RPS Ex : “00411850177 “
3
FILLER AN-11 RPS EX: “ “
4
FILLER AN-15 RPS EX: “ “
5
FILLER AN-30 RPS EX: “ “
6
FILLER AN-2 RPS EX: “ “
7
FILLER AN-1 RPS EX: “ “
8 BILLER CODE AN-4 RPS Ex : “1310”
1302 means PDAM Mitracom
9
FILLER AN-11 RPS EX: “ “
10 ADMIN FEE N-12 LPZ Ex : “000000075000”
11 FILLER AN-11 RPS EX: “ “
12 FILLER AN-12 RPS EX: “ “
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)