use strict;
my $str = 'i,i,i,u,br,br,p,p,p,p,br,br,br,br,div,div,div,div,br,br,br,p';
my $regex = qr/(,?(\w+))\1{2,}/mp;
my $subst = ',$2..$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";