re = /(,?(\w+))\1{2,}/m
str = 'i,i,i,u,br,br,p,p,p,p,br,br,br,br,div,div,div,div,br,br,br,p'
subst = ',$2..$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result