# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\*.*\R\K.*(?:\R(?!\*).*)*\R(?=\*)/[REPLACEMENT]\n/gm;t' <<< "********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
...
********** The last field will always remain unchanged **********
Unchanged content from last field"