re = /^\*.*\R\K.*(?:\R(?!\*).*)*\R(?=\*)/m
str = '********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
...
********** The last field will always remain unchanged **********
Unchanged content from last field'
subst = '[REPLACEMENT]\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result