const regex = /^\*.*\R\K.*(?:\R(?!\*).*)*\R(?=\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\*.*\\R\\K.*(?:\\R(?!\\*).*)*\\R(?=\\*)', 'gm')
const str = `********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
...
********** The last field will always remain unchanged **********
Unchanged content from last field`;
const subst = `[REPLACEMENT]\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);