import re
regex = re.compile(r"^\*.*\R\K.*(?:\R(?!\*).*)*\R(?=\*)", flags=re.MULTILINE)
test_str = ("********** Field #1 **********\n"
"Content inside Field #1\n"
"More content\n\n"
"********** Field #2 **********\n"
"Content inside Field #2\n"
"More content\n\n"
"...\n\n"
"********** The last field will always remain unchanged **********\n"
"Unchanged content from last field")
subst = "[REPLACEMENT]\\n"
result = regex.sub(subst, test_str)
if result:
print(result)