using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i).*Target\s*(\d+).*";
string substitution = @"target \1";
string input = @"abc123-Target 4-ufs
abc123-target4-ufs
geo.4
j123T4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}