import re
regex = re.compile(r"(?i).*Target\s*(\d+).*", flags=re.MULTILINE)
test_str = ("abc123-Target 4-ufs\n"
"abc123-target4-ufs\n"
"geo.4\n"
"j123T4")
subst = "target \\1"
result = regex.sub(subst, test_str)
if result:
print(result)