use strict;
my $str = 'abc123-Target 4-ufs
abc123-target4-ufs
geo.4
j123T4';
my $regex = qr/(?i).*Target\s*(\d+).*/mp;
my $subst = 'target \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";