$re = '/(?i).*Target\s*(\d+).*/m';
$str = 'abc123-Target 4-ufs
abc123-target4-ufs
geo.4
j123T4';
$subst = "target \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;