using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!asp|vb|c\#)\.[a-zA-Z]{2,6}\b";
string input = @"asp.net somedomain.com vb.net otherdomain.org wax.museum";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}