const regex = /(?<!asp|vb|c\#)\.[a-zA-Z]{2,6}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!asp|vb|c\\#)\\.[a-zA-Z]{2,6}\\b', 'g')
const str = `asp.net somedomain.com vb.net otherdomain.org wax.museum`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}