import re
regex = re.compile(r"(?<=[^\d]|^)\d{1,2}\/\d{1,2}(?<![^\d])", flags=re.MULTILINE)
test_str = ("1/2\n"
"11/22\n"
"111/222\n"
"11/33\n\n"
"444/444\n"
"44/44")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")