re = /(?<=[^\d]|^)\d{1,2}\/\d{1,2}(?<![^\d])/m
str = '1/2
11/22
111/222
11/33
444/444
44/44'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end