#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(|if\s*|IF|\s*and\s*|\s*AND\s*|\s*or\s*|\s*OR\s*)(\[[a-zA-Z\d\._=]*\])\s*(>=|<=|<|>|!=|==|\|\|)\s*("(.*)"|(-[\d]*|[\d]*))"
Local $sString = "if [plcTag.MeuInfo123] != "123 123 123 asdfasdf (@*&#(!@*&#(*"" & @CRLF & _
"if [plcTag.MeuInfo123] >= -1" & @CRLF & _
"if [plcTag.MeuInfo123] >= 1" & @CRLF & _
"if [plcTag.MeuInfo123] <= -1" & @CRLF & _
"if [plcTag.MeuInfo123] <= 1" & @CRLF & _
"if [plcTag.MeuInfo123] > 1" & @CRLF & _
"if [plcTag.MeuInfo123] > -1" & @CRLF & _
"if [plcTag.MeuInfo123] < 1" & @CRLF & _
"if [plcTag.MeuInfo123] < -1" & @CRLF & _
"if [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1" & @CRLF & _
"if [plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1" & @CRLF & _
"[plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")