const regex = /(|if\s*|IF|\s*and\s*|\s*AND\s*|\s*or\s*|\s*OR\s*)(\[[a-zA-Z\d\._=]*\])\s*(>=|<=|<|>|!=|==|\|\|)\s*("(.*)"|(-[\d]*|[\d]*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(|if\\s*|IF|\\s*and\\s*|\\s*AND\\s*|\\s*or\\s*|\\s*OR\\s*)(\\[[a-zA-Z\\d\\._=]*\\])\\s*(>=|<=|<|>|!=|==|\\|\\|)\\s*("(.*)"|(-[\\d]*|[\\d]*))', 'gm')
const str = `if [plcTag.MeuInfo123] != "123 123 123 asdfasdf (@*&#(!@*&#(*"
if [plcTag.MeuInfo123] >= -1
if [plcTag.MeuInfo123] >= 1
if [plcTag.MeuInfo123] <= -1
if [plcTag.MeuInfo123] <= 1
if [plcTag.MeuInfo123] > 1
if [plcTag.MeuInfo123] > -1
if [plcTag.MeuInfo123] < 1
if [plcTag.MeuInfo123] < -1
if [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1
if [plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1
[plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}