use strict;
my $str = 'if [plcTag.MeuInfo123] != "123 123 123 asdfasdf (@*&#(!@*&#(*"
if [plcTag.MeuInfo123] >= -1
if [plcTag.MeuInfo123] >= 1
if [plcTag.MeuInfo123] <= -1
if [plcTag.MeuInfo123] <= 1
if [plcTag.MeuInfo123] > 1
if [plcTag.MeuInfo123] > -1
if [plcTag.MeuInfo123] < 1
if [plcTag.MeuInfo123] < -1
if [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1
if [plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1
[plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1
';
my $regex = qr/(|if\s*|IF|\s*and\s*|\s*AND\s*|\s*or\s*|\s*OR\s*)(\[[a-zA-Z\d\._=]*\])\s*(>=|<=|<|>|!=|==|\|\|)\s*("(.*)"|(-[\d]*|[\d]*))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}