$re = '/(|if\s*|IF|\s*and\s*|\s*AND\s*|\s*or\s*|\s*OR\s*)(\[[a-zA-Z\d\._=]*\])\s*(>=|<=|<|>|!=|==|\|\|)\s*("(.*)"|(-[\d]*|[\d]*))/m';
$str = 'if [plcTag.MeuInfo123] != "123 123 123 asdfasdf (@*&#(!@*&#(*"
if [plcTag.MeuInfo123] >= -1
if [plcTag.MeuInfo123] >= 1
if [plcTag.MeuInfo123] <= -1
if [plcTag.MeuInfo123] <= 1
if [plcTag.MeuInfo123] > 1
if [plcTag.MeuInfo123] > -1
if [plcTag.MeuInfo123] < 1
if [plcTag.MeuInfo123] < -1
if [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1 and [plcTag.MeuInfo123] <= 1
if [plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1
[plcTag.MeuInfo123] <= 1 or [plcTag.MeuInfo123] <= 1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);